aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff King <peff@peff.net>2010-11-19 12:54:24 -0500
committerJunio C Hamano <gitster@pobox.com>2010-11-24 15:13:58 -0800
commit79c461d5b1139afa3d3997c7ef9ee521562b2a1a (patch)
tree9c2a448451de36743086d85de936736b0daca1ca /configure.ac
parent03276d94bcdb7d463a029936933898948c0669ac (diff)
downloadgit-79c461d5b1139afa3d3997c7ef9ee521562b2a1a.tar.gz
git-79c461d5b1139afa3d3997c7ef9ee521562b2a1a.tar.xz
docs: default to more modern toolset
When the ASCIIDOC8 and ASCIIDOC_NO_ROFF knobs were built, many people were still on asciidoc 7 and using older versions of docbook-xsl. These days, even the almost 2-year-old Debian stable needs these knobs turned. So let's turn them by default. The new knobs ASCIIDOC7 and ASCIIDOC_ROFF can be used to get the old behavior if people are on older systems. Signed-off-by: Jeff King <peff@peff.net> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index cc55b6d4f..e9ca1178b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,21 +398,21 @@ if test -n "$ASCIIDOC"; then
AC_MSG_CHECKING([for asciidoc version])
asciidoc_version=`$ASCIIDOC --version 2>/dev/null`
case "${asciidoc_version}" in
- asciidoc' '8*)
- ASCIIDOC8=YesPlease
+ asciidoc' '7*)
+ ASCIIDOC7=YesPlease
AC_MSG_RESULT([${asciidoc_version} > 7])
;;
- asciidoc' '7*)
- ASCIIDOC8=
+ asciidoc' '8*)
+ ASCIIDOC7=
AC_MSG_RESULT([${asciidoc_version}])
;;
*)
- ASCIIDOC8=
+ ASCIIDOC7=
AC_MSG_RESULT([${asciidoc_version} (unknown)])
;;
esac
fi
-AC_SUBST(ASCIIDOC8)
+AC_SUBST(ASCIIDOC7)
## Checks for libraries.