aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Walton <bwalton@artsci.utoronto.ca>2009-03-12 15:20:11 -0400
committerJunio C Hamano <gitster@pobox.com>2009-03-12 23:23:39 -0700
commita8304f7a70832a8e333fcf547589bc9d3bc0ca3c (patch)
tree52d9840f48007fbea5cadb073fec7d0156a8409b /configure.ac
parent29adc8baf997e143d8aeac9a0aeb257539d32e6d (diff)
downloadgit-a8304f7a70832a8e333fcf547589bc9d3bc0ca3c.tar.gz
git-a8304f7a70832a8e333fcf547589bc9d3bc0ca3c.tar.xz
configure: make iconv tests aware of user arguments
--with-iconv is now taken into account when doing the tests for iconv. If the user requests alternate handling for libiconv, the -liconv test is run before the -lc test. Signed-off-by: Ben Walton <bwalton@artsci.utoronto.ca> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 34 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index f4b8e49dc..6fe4bfe73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,20 +375,35 @@ int main(void)
return 0;
}
])
-AC_MSG_CHECKING([for iconv in -lc])
-AC_LINK_IFELSE(ICONVTEST_SRC,
+
+if test -n "$ICONVDIR"; then
+ lib_order="-liconv -lc"
+else
+ lib_order="-lc -liconv"
+fi
+
+NO_ICONV=YesPlease
+
+for l in $lib_order; do
+ if test "$l" = "-liconv"; then
+ NEEDS_LIBICONV=YesPlease
+ else
+ NEEDS_LIBICONV=
+ fi
+
+ old_LIBS="$LIBS"
+ LIBS="$LIBS $l"
+ AC_MSG_CHECKING([for iconv in $l])
+ AC_LINK_IFELSE(ICONVTEST_SRC,
[AC_MSG_RESULT([yes])
- NEEDS_LIBICONV=],
- [AC_MSG_RESULT([no])
- old_LIBS="$LIBS"
- LIBS="$LIBS -liconv"
- AC_MSG_CHECKING([for iconv in -liconv])
- AC_LINK_IFELSE(ICONVTEST_SRC,
- [AC_MSG_RESULT([yes])
- NEEDS_LIBICONV=YesPlease],
- [AC_MSG_RESULT([no])
- NO_ICONV=YesPlease])
- LIBS="$old_LIBS"])
+ NO_ICONV=
+ break],
+ [AC_MSG_RESULT([no])])
+ LIBS="$old_LIBS"
+done
+
+#in case of break
+LIBS="$old_LIBS"
GIT_UNSTASH_FLAGS($ICONVDIR)
@@ -455,13 +470,18 @@ int main(void)
return 0;
}
]])
+
+GIT_STASH_FLAGS($ICONVDIR)
+
AC_MSG_CHECKING([for old iconv()])
AC_COMPILE_IFELSE(OLDICONVTEST_SRC,
[AC_MSG_RESULT([no])],
[AC_MSG_RESULT([yes])
OLD_ICONV=UnfortunatelyYes])
-AC_SUBST(OLD_ICONV)
+GIT_UNSTASH_FLAGS($ICONVDIR)
+
+AC_SUBST(OLD_ICONV)
## Checks for typedefs, structures, and compiler characteristics.
AC_MSG_NOTICE([CHECKS for typedefs, structures, and compiler characteristics])