aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Narebski <jnareb@gmail.com>2006-08-08 18:38:06 +0200
committerJunio C Hamano <junkio@cox.net>2006-08-08 13:34:00 -0700
commitaf6058cc2bf309631fc7f5cd44fb39b567286506 (patch)
tree988f8ce3df698dad62c735d51ff61ebb1e3d1c3c /configure.ac
parentb52b1d433b47888d79a73a514aa3430257cba863 (diff)
downloadgit-af6058cc2bf309631fc7f5cd44fb39b567286506.tar.gz
git-af6058cc2bf309631fc7f5cd44fb39b567286506.tar.xz
autoconf: Improvements in NO_PYTHON/PYTHON_PATH handling
Unset NO_PYTHON for --with-python without arguments, and when PYTHON_PATH is set. Do not check for PYTHON_PATH if it is set via --with-python=PYTHON_PATH. Prefer "python" over version specific names such as "python2.4". Signed-off-by: Jakub Narebski <jnareb@gmail.com> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index c2ddd9b6e..c27a994da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,7 +105,10 @@ AC_ARG_WITH(python,[AS_HELP_STRING([--with-python=PATH], [provide PATH to python
AS_HELP_STRING([--no-python], [don't use python scripts])],
[if test "$withval" = "no"; then \
NO_PYTHON=YesPlease; \
- elif test "$withval" != "yes"; then \
+ elif test "$withval" = "yes"; then \
+ NO_PYTHON=; \
+ else \
+ NO_PYTHON=; \
PYTHON_PATH=$withval; \
fi; \
])
@@ -138,15 +141,15 @@ AC_CHECK_PROGS(TAR, [gtar tar])
# Define NO_PYTHON if you want to lose all benefits of the recursive merge.
# Define PYTHON_PATH to provide path to Python.
if test -z "$NO_PYTHON"; then
- AC_PATH_PROGS(PYTHON_PATH, [python2.4 python2.3 python2 python])
+ if test -z "$PYTHON_PATH"; then
+ AC_PATH_PROGS(PYTHON_PATH, [python python2.4 python2.3 python2])
+ fi
if test -n "$PYTHON_PATH"; then
GIT_CONF_APPEND_LINE([PYTHON_PATH=@PYTHON_PATH@])
- else
- GIT_CONF_APPEND_LINE([NO_PYTHON=@NO_PYTHON@])
+ NO_PYTHON=""
fi
-else
- GIT_CONF_APPEND_LINE([NO_PYTHON=@NO_PYTHON@])
fi
+GIT_CONF_APPEND_LINE([NO_PYTHON=@NO_PYTHON@])
## Checks for libraries.