aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Narebski <jnareb@gmail.com>2006-07-08 23:07:09 +0200
committerJunio C Hamano <junkio@cox.net>2006-07-09 02:20:32 -0700
commitd3a6db981179a1dc772768ff6af0414d17848d93 (patch)
tree86768ce7c7c8c80f5d5ab5658930a722b006bf8d /configure.ac
parent633b423961df659fbf110fd7b127ebc9a0a38277 (diff)
downloadgit-d3a6db981179a1dc772768ff6af0414d17848d93.tar.gz
git-d3a6db981179a1dc772768ff6af0414d17848d93.tar.xz
autoconf: Preparing the way for autodetection
Prepares configure.ac to output autodetected and selected (by using --with/--without and --enable/disable parameters to generated ./configure script) building configuration in "git style", i.e. by appending appropriate variables to output file config.mak.autogen (via temporary file config.mak.append). Signed-off-by: Jakub Narebski <jnareb@gmail.com> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 12039a124..e68d4163c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,8 +7,19 @@ AC_INIT([git], [1.4.1], [git@vger.kernel.org])
AC_CONFIG_SRCDIR([git.c])
config_file=config.mak.autogen
+config_append=config.mak.append
config_in=config.mak.in
+echo "# ${config_append}. Generated by configure." > "${config_append}"
+
+
+## Definitions of macros
+# GIT_CONF_APPEND_LINE(LINE)
+# --------------------------
+# Append LINE to file ${config_append}
+AC_DEFUN([GIT_CONF_APPEND_LINE],
+[echo "$1" >> "${config_append}"])# GIT_CONF_APPEND_LINE
+
## Checks for programs.
# Define NO_PYTHON if you want to loose all benefits of the recursive merge.
@@ -121,6 +132,10 @@ config_in=config.mak.in
# Define USE_STDEV below if you want git to care about the underlying device
# change being considered an inode change from the update-cache perspective.
+
## Output files
-AC_CONFIG_FILES(["${config_file}":"${config_in}"])
+AC_CONFIG_FILES(["${config_file}":"${config_in}":"${config_append}"])
AC_OUTPUT
+
+## Cleanup
+rm -f "${config_append}"