aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <git@mlists.thewrittenword.com>2010-05-14 09:31:42 +0000
committerJunio C Hamano <gitster@pobox.com>2010-05-31 17:36:27 -0700
commite88a135bc55a974ea04576ccc014c5e2bdc4b892 (patch)
treebace841b2f0da79db51999ccf457e325f5b59cbc /configure.ac
parent5a857c74baa96c4b20cdf9cab83a77972e6560de (diff)
downloadgit-e88a135bc55a974ea04576ccc014c5e2bdc4b892.tar.gz
git-e88a135bc55a974ea04576ccc014c5e2bdc4b892.tar.xz
Some platforms lack socklen_t type
Some platforms do not have a socklen_t type declaration. Signed-off-by: Gary V. Vaughan <gary@thewrittenword.com> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b97ee6dbb..df831c35d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -633,6 +633,12 @@ AC_SUBST(OLD_ICONV)
## Checks for typedefs, structures, and compiler characteristics.
AC_MSG_NOTICE([CHECKS for typedefs, structures, and compiler characteristics])
#
+TYPE_SOCKLEN_T
+case $ac_cv_type_socklen_t in
+ yes) ;;
+ *) AC_SUBST([SOCKLEN_T], [$git_cv_socklen_t_equiv]) ;;
+esac
+
# Define NO_D_INO_IN_DIRENT if you don't have d_ino in your struct dirent.
AC_CHECK_MEMBER(struct dirent.d_ino,
[NO_D_INO_IN_DIRENT=],