aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRyan Anderson <ryan@michonline.com>2005-07-22 01:55:56 -0400
committerLinus Torvalds <torvalds@g5.osdl.org>2005-07-23 11:05:58 -0700
commit71fb3de0eed70bba1c7e28c8a0a2968efc48b9f3 (patch)
treeffb6bf457ccc746328e7b693ee2b78a472f34ceb /debian
parent4311d328fee11fbd80862e3c5de06a26a0e80046 (diff)
downloadgit-71fb3de0eed70bba1c7e28c8a0a2968efc48b9f3.tar.gz
git-71fb3de0eed70bba1c7e28c8a0a2968efc48b9f3.tar.xz
[PATCH] Deb packages should include the binaries
The Deb packages were missing a dependency on "build install" from the binary target - this fixes that, and cleans up some inconsistencies elsewhere in the rulesets. Traditionally, Debian packaging uses a file called "build-stamp" (or "install-stamp", etc) in the main source tree. The initial deb package support for Git tried to move this "build-stamp" file into the debian/ directory, but some instances were missed. That problem, however, was incidental - the real fix is the missing dependency mentioned above. Signed-off-by: Ryan Anderson <ryan@michonline.com> Signed-off-by: Junio C Hamano <junkio@cox.net> Signed-off-by: Linus Torvalds <torvalds@osdl.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules10
3 files changed, 13 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 18bd6a77f..7cbf2f4db 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,11 @@
+git-core (0.99-1) unstable; urgency=low
+
+ * Update deb package support to build correctly.
+
+ -- Ryan Anderson <ryan@michonline.com> Thu, 21 Jul 2005 02:03:32 -0400
+
git-core (0.99-0) unstable; urgency=low
-
+
* Initial deb package support
-- Eric Biederman <ebiederm@xmission.com> Tue, 12 Jul 2005 10:57:51 -0600
diff --git a/debian/control b/debian/control
index a9732ea59..a774a629b 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Standards-Version: 3.6.1
Package: git-core
Architecture: any
-Depends: ${shlibs:Depends}, shellutils, diff, rsync, rcs
+Depends: ${misc:Depends}, shellutils, diff, rsync, rcs
Description: The git content addressable filesystem
GIT comes in two layers. The bottom layer is merely an extremely fast
and flexible filesystem-based database designed to store directory trees
diff --git a/debian/rules b/debian/rules
index 944510160..aff43b836 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,8 +21,8 @@ DESTDIR := $(CURDIR)/debian/tmp
DOC_DESTDIR := $(DESTDIR)/usr/share/doc/git-core/
MAN_DESTDIR := $(DESTDIR)/$(MANDIR)
-build: build-stamp
-build-stamp:
+build: debian/build-stamp
+debian/build-stamp:
dh_testdir
$(MAKE) all doc
touch debian/build-stamp
@@ -36,7 +36,7 @@ debian-clean:
clean: debian-clean
$(MAKE) clean
-install: debian/build-stamp
+install: build
dh_testdir
dh_testroot
dh_clean -k
@@ -47,9 +47,9 @@ install: debian/build-stamp
mkdir -p $(DOC_DESTDIR)
find $(DOC) '(' -name '*.txt' -o -name '*.html' ')' -exec install {} $(DOC_DESTDIR) ';'
- dh_install --sourcedir=$(DESTDIR)
+ dh_install --list-missing --sourcedir=$(DESTDIR)
-binary:
+binary: build install
dh_testdir
dh_testroot
dh_installchangelogs