aboutsummaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorPetr Baudis <pasky@suse.cz>2006-09-23 20:20:47 +0200
committerJunio C Hamano <junkio@cox.net>2006-09-23 14:02:40 -0700
commit18b0fc1ce1ef92716d4c5d5c7acd5d5a61a0a556 (patch)
treeedbda9f5f6b37cd63d5c216ee0ad3aebce85c0e8 /perl/Makefile.PL
parent81a71734bb73c2def1e86de88fb8de9fb6379cc5 (diff)
downloadgit-18b0fc1ce1ef92716d4c5d5c7acd5d5a61a0a556.tar.gz
git-18b0fc1ce1ef92716d4c5d5c7acd5d5a61a0a556.tar.xz
Git.pm: Kill Git.xs for now
This patch removes Git.xs from the repository for the time being. This should hopefully enable Git.pm to finally make its way to master. Git.xs is not going away forever. When the Git libification makes some progress, it will hopefully return (but most likely as an optional component, due to the portability woes) since the performance boosts are really important for applications like Gitweb or Cogito. It needs to go away now since it is not really reliable in case you use it for several repositories in the scope of a single process, and that is not possible to fix without some either very ugly or very intrusive core changes. Rest in peace. (While you can.) Signed-off-by: Petr Baudis <pasky@suse.cz> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL9
1 files changed, 1 insertions, 8 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index ef9d82d7b..de73235e4 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -3,12 +3,7 @@ use ExtUtils::MakeMaker;
sub MY::postamble {
return <<'MAKE_FRAG';
instlibdir:
- @echo '$(INSTALLSITEARCH)'
-
-check:
- perl -MDevel::PPPort -le 'Devel::PPPort::WriteFile(".ppport.h")' && \
- perl .ppport.h --compat-version=5.6.0 Git.xs && \
- rm .ppport.h
+ @echo '$(INSTALLSITELIB)'
MAKE_FRAG
}
@@ -29,7 +24,5 @@ WriteMakefile(
NAME => 'Git',
VERSION_FROM => 'Git.pm',
PM => \%pm,
- MYEXTLIB => '../libgit.a',
- INC => '-I. -I..',
%extra
);