aboutsummaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2006-08-13 04:13:25 -0700
committerJunio C Hamano <junkio@cox.net>2006-08-13 10:25:00 -0700
commit4c5cf8c44ce06a79da5bafd4a92e6d6f598cea2e (patch)
treee9ed3186d57d04ea25696f87c6aa691635d72368 /perl/Makefile.PL
parent9673198ee867cea4ed70d2cf54c1a2eb8f27bb46 (diff)
downloadgit-4c5cf8c44ce06a79da5bafd4a92e6d6f598cea2e.tar.gz
git-4c5cf8c44ce06a79da5bafd4a92e6d6f598cea2e.tar.xz
pass DESTDIR to the generated perl/Makefile
Makes life for binary packagers easier, as the Perl modules will be installed inside DESTDIR. Signed-off-by: Eric Wong <normalperson@yhbt.net> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL4
1 files changed, 4 insertions, 0 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 97ee9af9c..ef9d82d7b 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -22,10 +22,14 @@ if ($@) {
$pm{'private-Error.pm'} = '$(INST_LIBDIR)/Error.pm';
}
+my %extra;
+$extra{DESTDIR} = $ENV{DESTDIR} if $ENV{DESTDIR};
+
WriteMakefile(
NAME => 'Git',
VERSION_FROM => 'Git.pm',
PM => \%pm,
MYEXTLIB => '../libgit.a',
INC => '-I. -I..',
+ %extra
);