summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-07-13 18:07:16 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2017-07-13 18:07:16 +0200
commitc803bf07a6ec6a8288d7604b54cc5e7b47339279 (patch)
tree8d81d46e5afa64ac102cb29ffc44ca4a235c8554
parent90c15cc0beda1039c5b27bf33e03dfed3276562c (diff)
downloadgentoo-c803bf07a6ec6a8288d7604b54cc5e7b47339279.tar.gz
gentoo-c803bf07a6ec6a8288d7604b54cc5e7b47339279.tar.xz
x11-wm/stumpwm-contrib: Sync with lisp overlay
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--x11-wm/stumpwm-contrib/Manifest1
-rw-r--r--x11-wm/stumpwm-contrib/stumpwm-contrib-20170713.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/stumpwm-contrib/Manifest b/x11-wm/stumpwm-contrib/Manifest
index 9e9fd383bf7..135b7e28f57 100644
--- a/x11-wm/stumpwm-contrib/Manifest
+++ b/x11-wm/stumpwm-contrib/Manifest
@@ -1 +1,2 @@
DIST stumpwm-contrib-20170314.tar.bz2 54099 SHA256 a6c48eb81f55b79805c16660db0e38d7f0451be1709cb86ef16244f0319315b3 SHA512 2c6a0f4e3f7e0df7de6a71b81feae73ae9a9eeb0fca96597e68aa015d86cd0d10d54313914f6a68bf284b1a1455c668a1727d9ae6aef54c393f9e50183da6ab2 WHIRLPOOL 939223bcbc0bd7517c7b241c82eb0ed24744f5e0cd979e1051ef410fbfcb56078c796c6c1ec452d6232766172b28c5b5138bbfb7233ee59e268aa50691db14d1
+DIST stumpwm-contrib-20170713.tar.bz2 54197 SHA256 b420fd526566210e179d9e1b23f62781971cb522158b6c84f04d55403e458f5f SHA512 01de3f543ceb66c35d1e00a7d598c71274da03c40b90d9dcd7ea704f98497fe3c9ef6b33d25db1dd411a503171fd8911137c385c9089a9404eb579c39eb8082a WHIRLPOOL 4149f353e9264132fd7ee128b9e3cc1e30a672d771ac677ec77dec5fb8c05f8fba557e1d8af14031d37087bd9bbe644a99329ea0a7323401b0908fb10008c09d
diff --git a/x11-wm/stumpwm-contrib/stumpwm-contrib-20170713.ebuild b/x11-wm/stumpwm-contrib/stumpwm-contrib-20170713.ebuild
new file mode 100644
index 00000000000..7ceecc4fbfe
--- /dev/null
+++ b/x11-wm/stumpwm-contrib/stumpwm-contrib-20170713.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/stumpwm/${PN}"
+else
+ SRC_URI="https://dev.gentoo.org/~nimiux/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Extension Modules for StumpWM"
+HOMEPAGE="https://github.com/stumpwm/stumpwm-contrib/"
+
+LICENSE="GPL-2 GPL-3 BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-wm/stumpwm-0.9.9"
+
+CONTRIBCATEGORIES="media modeline minor-mode util"
+
+src_install() {
+ common-lisp-install-sources -t all ${CONTRIBCATEGORIES}
+ dobin util/stumpish/stumpish
+ dodoc README.org
+}