summaryrefslogtreecommitdiff
path: root/app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild')
-rw-r--r--app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild b/app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild
new file mode 100644
index 00000000000..6fce7506aa8
--- /dev/null
+++ b/app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}${PV/./-}"
+DESCRIPTION="Simple Perl/Tk GUI to manage a small certification authority"
+HOMEPAGE="http://tinyca.sm-zone.net/"
+SRC_URI="http://tinyca.sm-zone.net/${MY_P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+LANGS="en de cs es sv"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.7e:0=
+ dev-perl/Locale-gettext
+ >=virtual/perl-MIME-Base64-2.12
+ >=dev-perl/gtk2-perl-1.072"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.7.3-compositefix.patch"
+ epatch "${FILESDIR}/${P}-openssl-1.patch"
+ epatch "${FILESDIR}/${P}-perl-5.18.patch"
+ sed -i -e 's:./lib:/usr/share/tinyca/lib:g' \
+ -e 's:./templates:/usr/share/tinyca/templates:g' \
+ -e 's:./locale:/usr/share/locale:g' "${S}/tinyca2" || die
+}
+
+src_compile() {
+ emake -C po
+}
+
+locale_install() {
+ insinto /usr/share/locale/$@/LC_MESSAGES/
+ doins locale/$@/LC_MESSAGES/tinyca2.mo
+}
+
+src_install() {
+ newbin tinyca2 tinyca
+ insinto /usr/share/tinyca/lib
+ doins lib/*.pm
+ insinto /usr/share/tinyca/lib/GUI
+ doins lib/GUI/*.pm
+ insinto /usr/share/tinyca/templates
+ doins templates/*
+ insinto /usr/share/
+ strip-linguas ${LANGS}
+ local l
+ for l in ${LANGS}; do
+ if [ "$l" != "en" ]; then
+ use linguas_$l && locale_install $l
+ fi
+ done
+}