summaryrefslogtreecommitdiff
path: root/app-portage/epkg
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/epkg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/epkg')
-rw-r--r--app-portage/epkg/Manifest3
-rw-r--r--app-portage/epkg/epkg-0.2.ebuild24
-rw-r--r--app-portage/epkg/epkg-0.3.ebuild25
-rw-r--r--app-portage/epkg/epkg-0.4.ebuild25
-rw-r--r--app-portage/epkg/metadata.xml11
5 files changed, 88 insertions, 0 deletions
diff --git a/app-portage/epkg/Manifest b/app-portage/epkg/Manifest
new file mode 100644
index 00000000000..04d5cde8896
--- /dev/null
+++ b/app-portage/epkg/Manifest
@@ -0,0 +1,3 @@
+DIST epkg-0.2.tar.gz 702 SHA256 93e7171a31800e1e8c69f14fb43d1738e7fda595b4eab9a045374e28708af8f4 SHA512 bbb3579be7138dcaee177b31deea406c3775e9f9ca01b79704a0b13279a5ebc1eaa1f9bbf47067370332c58102acdbc0fab718923c34e4cfcb062ffff773b165 WHIRLPOOL 2bfd1982fb2422f410f5c2a202a144735baad8b0adbefb9d1b4830c775b0d842f27b970d213ad31ceec1041842e1499bf6230de048734cebd28ea7f1c7dc587e
+DIST epkg-0.3.tar.gz 2926 SHA256 f996ab4aaa64c42d1e4635da46e65d57445d2f6c9a059e0b471dd140d5798b5e SHA512 2b815305c00b50a7a7e433345dd722591a1106edbf9b79715e70296489f4203fc1585a9abff826413d89ce8dde2680a78c375659fd1767e8c13e6fe1b48d4c40 WHIRLPOOL 5caba1df0fc8c1e7a79fa2cbb44e6245b32f0bfda2f5f27feec9e7e779bf047947e0adf9d10045f05cfaaa5b665be25595bce901b23bc7024df76ff496dfeaad
+DIST epkg-0.4.tar.gz 3696 SHA256 7b3f51ed9fbbc931d2378525595379559e6d893d0c71b41a4529ea6f91b853a7 SHA512 2b9ef0e2d0ec123a1e333403371d0d4d750bc5247a05771dc2f694d225ea5db2702dbc9a126cec1d0ddca38dffa837dd66acaa046ac94d00a28890f3e3cd7879 WHIRLPOOL 63bf5fc3ce3017ad708cb9e42585e934369fb9249d9910f49bce52a6c71edf2729df8d065b80dc4dc4555433538b0f457531566603492412d1512bb227d4104c
diff --git a/app-portage/epkg/epkg-0.2.ebuild b/app-portage/epkg/epkg-0.2.ebuild
new file mode 100644
index 00000000000..7baf7f17a36
--- /dev/null
+++ b/app-portage/epkg/epkg-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A simple portage wrapper which works like other package managers"
+HOMEPAGE="http://github.com/jdhore/epkg"
+SRC_URI="https://github.com/jdhore/${PN}/archive/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${P}"
+DEPEND=""
+RDEPEND="app-portage/eix
+ app-portage/gentoolkit
+ sys-apps/portage"
+
+src_install() {
+ dobin epkg
+}
diff --git a/app-portage/epkg/epkg-0.3.ebuild b/app-portage/epkg/epkg-0.3.ebuild
new file mode 100644
index 00000000000..98d31f4d6ea
--- /dev/null
+++ b/app-portage/epkg/epkg-0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A simple portage wrapper which works like other package managers"
+HOMEPAGE="http://github.com/jdhore/epkg"
+SRC_URI="https://github.com/jdhore/${PN}/archive/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${P}"
+DEPEND=""
+RDEPEND="app-portage/eix
+ app-portage/gentoolkit
+ sys-apps/portage"
+
+src_install() {
+ dobin epkg
+ doman doc/epkg.1
+}
diff --git a/app-portage/epkg/epkg-0.4.ebuild b/app-portage/epkg/epkg-0.4.ebuild
new file mode 100644
index 00000000000..243c96646d8
--- /dev/null
+++ b/app-portage/epkg/epkg-0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A simple portage wrapper which works like other package managers"
+HOMEPAGE="http://github.com/jdhore/epkg"
+SRC_URI="https://github.com/jdhore/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${P}"
+DEPEND=""
+RDEPEND="app-portage/eix
+ app-portage/gentoolkit
+ sys-apps/portage"
+
+src_install() {
+ dobin epkg
+ doman doc/epkg.1
+}
diff --git a/app-portage/epkg/metadata.xml b/app-portage/epkg/metadata.xml
new file mode 100644
index 00000000000..5ad189835eb
--- /dev/null
+++ b/app-portage/epkg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jdhore@gentoo.org</email>
+ <name>Jeff Horelick</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jdhore/epkg</remote-id>
+ </upstream>
+</pkgmetadata>