summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-06 17:19:49 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-06 17:22:40 +0100
commit38f5095024e13d3c9e68ea5049afa642a815f7f2 (patch)
tree9976ba07a8f193b8ec0178b6a31849d9431a7aa5 /dev-db
parent3086bff0d05c99cd74f7515ea5e8c179f273c254 (diff)
downloadgentoo-38f5095024e13d3c9e68ea5049afa642a815f7f2.tar.gz
gentoo-38f5095024e13d3c9e68ea5049afa642a815f7f2.tar.xz
dev-db/postgresql: Remove linguas_* from IUSE.
Also move definition of supported locales to a local variable. How could this possibly have worked, with an assignment of the LINGUAS variable in global scope? Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/postgresql-10.0-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-10.0.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-10.1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.2.19.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.2.22.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.2.23-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.2.23.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.2.24.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.3.15.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.3.18.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.3.19-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.3.19.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.3.20.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.4.10.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.4.13.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.4.14-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.4.14.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.4.15.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.5.10.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.5.5.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.5.8.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.5.9-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.5.9.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.6.4.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.6.5-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.6.5.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9.6.6.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild16
28 files changed, 168 insertions, 280 deletions
diff --git a/dev-db/postgresql/postgresql-10.0-r1.ebuild b/dev-db/postgresql/postgresql-10.0-r1.ebuild
index 18fea4c814b..1fc58e6071a 100644
--- a/dev-db/postgresql/postgresql-10.0-r1.ebuild
+++ b/dev-db/postgresql/postgresql-10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr zh_CN
- zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl python +readline
selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-10.0.ebuild b/dev-db/postgresql/postgresql-10.0.ebuild
index f8c09bb804c..c3b086316a3 100644
--- a/dev-db/postgresql/postgresql-10.0.ebuild
+++ b/dev-db/postgresql/postgresql-10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr zh_CN
- zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl python +readline
selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-10.1.ebuild b/dev-db/postgresql/postgresql-10.1.ebuild
index f4041b02f99..0a9959f3406 100644
--- a/dev-db/postgresql/postgresql-10.1.ebuild
+++ b/dev-db/postgresql/postgresql-10.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr zh_CN
- zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl python +readline
selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.2.19.ebuild b/dev-db/postgresql/postgresql-9.2.19.ebuild
index 008123508d6..2300704b204 100644
--- a/dev-db/postgresql/postgresql-9.2.19.ebuild
+++ b/dev-db/postgresql/postgresql-9.2.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.2.22.ebuild b/dev-db/postgresql/postgresql-9.2.22.ebuild
index 6da7c31e6c4..af4ae8663d1 100644
--- a/dev-db/postgresql/postgresql-9.2.22.ebuild
+++ b/dev-db/postgresql/postgresql-9.2.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.2.23-r1.ebuild b/dev-db/postgresql/postgresql-9.2.23-r1.ebuild
index e51086d898b..3b6ee92300e 100644
--- a/dev-db/postgresql/postgresql-9.2.23-r1.ebuild
+++ b/dev-db/postgresql/postgresql-9.2.23-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.2.23.ebuild b/dev-db/postgresql/postgresql-9.2.23.ebuild
index b32870c3a84..55328415150 100644
--- a/dev-db/postgresql/postgresql-9.2.23.ebuild
+++ b/dev-db/postgresql/postgresql-9.2.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.2.24.ebuild b/dev-db/postgresql/postgresql-9.2.24.ebuild
index b49e5f7a544..1159151f7af 100644
--- a/dev-db/postgresql/postgresql-9.2.24.ebuild
+++ b/dev-db/postgresql/postgresql-9.2.24.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.3.15.ebuild b/dev-db/postgresql/postgresql-9.3.15.ebuild
index 8a187562c90..4f8c108842a 100644
--- a/dev-db/postgresql/postgresql-9.3.15.ebuild
+++ b/dev-db/postgresql/postgresql-9.3.15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.3.18.ebuild b/dev-db/postgresql/postgresql-9.3.18.ebuild
index 37b53c36ff1..ef402d99bd3 100644
--- a/dev-db/postgresql/postgresql-9.3.18.ebuild
+++ b/dev-db/postgresql/postgresql-9.3.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.3.19-r1.ebuild b/dev-db/postgresql/postgresql-9.3.19-r1.ebuild
index ff42ac626f7..8a1a8f9bea7 100644
--- a/dev-db/postgresql/postgresql-9.3.19-r1.ebuild
+++ b/dev-db/postgresql/postgresql-9.3.19-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.3.19.ebuild b/dev-db/postgresql/postgresql-9.3.19.ebuild
index 41dc55cea87..b84e6edd3db 100644
--- a/dev-db/postgresql/postgresql-9.3.19.ebuild
+++ b/dev-db/postgresql/postgresql-9.3.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.3.20.ebuild b/dev-db/postgresql/postgresql-9.3.20.ebuild
index 5afb997c778..9962b3bd005 100644
--- a/dev-db/postgresql/postgresql-9.3.20.ebuild
+++ b/dev-db/postgresql/postgresql-9.3.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.4.10.ebuild b/dev-db/postgresql/postgresql-9.4.10.ebuild
index 61f957f5322..bba0449641e 100644
--- a/dev-db/postgresql/postgresql-9.4.10.ebuild
+++ b/dev-db/postgresql/postgresql-9.4.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.4.13.ebuild b/dev-db/postgresql/postgresql-9.4.13.ebuild
index f17788a2300..552f2428fda 100644
--- a/dev-db/postgresql/postgresql-9.4.13.ebuild
+++ b/dev-db/postgresql/postgresql-9.4.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.4.14-r1.ebuild b/dev-db/postgresql/postgresql-9.4.14-r1.ebuild
index d77190ea0a5..c799ad1927a 100644
--- a/dev-db/postgresql/postgresql-9.4.14-r1.ebuild
+++ b/dev-db/postgresql/postgresql-9.4.14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.4.14.ebuild b/dev-db/postgresql/postgresql-9.4.14.ebuild
index a5ce342394d..c287bfe08a6 100644
--- a/dev-db/postgresql/postgresql-9.4.14.ebuild
+++ b/dev-db/postgresql/postgresql-9.4.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.4.15.ebuild b/dev-db/postgresql/postgresql-9.4.15.ebuild
index 7283bd89cbe..13530394ab5 100644
--- a/dev-db/postgresql/postgresql-9.4.15.ebuild
+++ b/dev-db/postgresql/postgresql-9.4.15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.5.10.ebuild b/dev-db/postgresql/postgresql-9.5.10.ebuild
index 360d90c28bc..28e6fc826d3 100644
--- a/dev-db/postgresql/postgresql-9.5.10.ebuild
+++ b/dev-db/postgresql/postgresql-9.5.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.5.5.ebuild b/dev-db/postgresql/postgresql-9.5.5.ebuild
index 1393518bebd..81221d49db5 100644
--- a/dev-db/postgresql/postgresql-9.5.5.ebuild
+++ b/dev-db/postgresql/postgresql-9.5.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.5.8.ebuild b/dev-db/postgresql/postgresql-9.5.8.ebuild
index 0e5a7b5009f..fa7874ed7e5 100644
--- a/dev-db/postgresql/postgresql-9.5.8.ebuild
+++ b/dev-db/postgresql/postgresql-9.5.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.5.9-r1.ebuild b/dev-db/postgresql/postgresql-9.5.9-r1.ebuild
index 721f27ae0f9..6f8aca3f8ae 100644
--- a/dev-db/postgresql/postgresql-9.5.9-r1.ebuild
+++ b/dev-db/postgresql/postgresql-9.5.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.5.9.ebuild b/dev-db/postgresql/postgresql-9.5.9.ebuild
index 5db745095a8..68ba88f280d 100644
--- a/dev-db/postgresql/postgresql-9.5.9.ebuild
+++ b/dev-db/postgresql/postgresql-9.5.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,21 +18,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.6.4.ebuild b/dev-db/postgresql/postgresql-9.6.4.ebuild
index 98b451d4498..f588eee23f3 100644
--- a/dev-db/postgresql/postgresql-9.6.4.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.6.5-r1.ebuild b/dev-db/postgresql/postgresql-9.6.5-r1.ebuild
index df077d0dfb8..a777d660e8f 100644
--- a/dev-db/postgresql/postgresql-9.6.5-r1.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.6.5.ebuild b/dev-db/postgresql/postgresql-9.6.5.ebuild
index 66369e14a21..821aa3eeee0 100644
--- a/dev-db/postgresql/postgresql-9.6.5.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9.6.6.ebuild b/dev-db/postgresql/postgresql-9.6.6.ebuild
index eb48559dd4d..08aa80472d1 100644
--- a/dev-db/postgresql/postgresql-9.6.6.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index af236abbcc1..151af8e7d57 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -19,21 +19,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
- zh_CN zh_TW"
IUSE="kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}