summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-2.7.10-r1.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-30 21:07:29 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-30 21:13:46 +0200
commitb7a4174e075a922a255c0ff4a6ebd4f6d0437c61 (patch)
tree8295e33b5ca69551939e30c2d2b765c50c55568c /dev-lang/python/python-2.7.10-r1.ebuild
parent253681c1362663f2f520ec36c564852877729a91 (diff)
downloadgentoo-b7a4174e075a922a255c0ff4a6ebd4f6d0437c61.tar.gz
gentoo-b7a4174e075a922a255c0ff4a6ebd4f6d0437c61.tar.xz
dev-lang/python: Remove remnants of python-updater
Remove the remaining dependencies on deprecated python-updater, and update the postinst messages appropriately. For Python 2.7, the message has been removed altogether since it is the oldest version supported by PYTHON_TARGETS. For the remaining versions, just inform about potential PYTHON_TARGETS changes necessary. The modified versions are not revision-bumped to avoid unnecessary rebuilds due to a minor change. The versions that are still newest-visible (i.e. not replaced by another version or revision bump) will be bumped when python-updater is lastrited.
Diffstat (limited to 'dev-lang/python/python-2.7.10-r1.ebuild')
-rw-r--r--dev-lang/python/python-2.7.10-r1.ebuild17
1 files changed, 2 insertions, 15 deletions
diff --git a/dev-lang/python/python-2.7.10-r1.ebuild b/dev-lang/python/python-2.7.10-r1.ebuild
index 5715577a336..aaf1b143e04 100644
--- a/dev-lang/python/python-2.7.10-r1.ebuild
+++ b/dev-lang/python/python-2.7.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -64,8 +64,7 @@ DEPEND="${RDEPEND}
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
doc? ( dev-python/python-docs:${SLOT} )"
-PDEPEND="app-eselect/eselect-python
- app-admin/python-updater"
+PDEPEND="app-eselect/eselect-python"
S="${WORKDIR}/${MY_P}"
@@ -329,12 +328,6 @@ src_install() {
python_domodule epython.py
}
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version "${CATEGORY}/${PN}:2.7"; then
- python_updater_warning="1"
- fi
-}
-
eselect_python_update() {
if [[ -z "$(eselect python show)" || ! -f "${EROOT}usr/bin/$(eselect python show)" ]]; then
eselect python update
@@ -347,12 +340,6 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should switch active version of Python ${PV%%.*} and run"
- ewarn "'python-updater [options]' to rebuild Python modules."
- fi
}
pkg_postrm() {