summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-2.7.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.7.10-r1.ebuild')
-rw-r--r--dev-lang/python/python-2.7.10-r1.ebuild17
1 files changed, 2 insertions, 15 deletions
diff --git a/dev-lang/python/python-2.7.10-r1.ebuild b/dev-lang/python/python-2.7.10-r1.ebuild
index 5715577a336..aaf1b143e04 100644
--- a/dev-lang/python/python-2.7.10-r1.ebuild
+++ b/dev-lang/python/python-2.7.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -64,8 +64,7 @@ DEPEND="${RDEPEND}
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
doc? ( dev-python/python-docs:${SLOT} )"
-PDEPEND="app-eselect/eselect-python
- app-admin/python-updater"
+PDEPEND="app-eselect/eselect-python"
S="${WORKDIR}/${MY_P}"
@@ -329,12 +328,6 @@ src_install() {
python_domodule epython.py
}
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version "${CATEGORY}/${PN}:2.7"; then
- python_updater_warning="1"
- fi
-}
-
eselect_python_update() {
if [[ -z "$(eselect python show)" || ! -f "${EROOT}usr/bin/$(eselect python show)" ]]; then
eselect python update
@@ -347,12 +340,6 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should switch active version of Python ${PV%%.*} and run"
- ewarn "'python-updater [options]' to rebuild Python modules."
- fi
}
pkg_postrm() {