summaryrefslogtreecommitdiff
path: root/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/dbus-glib/dbus-glib-0.102.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/dbus-glib/dbus-glib-0.102.ebuild')
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.102.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/dbus-glib/dbus-glib-0.102.ebuild b/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
new file mode 100644
index 00000000000..8678e12e9a3
--- /dev/null
+++ b/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit bash-completion-r1 eutils multilib-minimal
+
+DESCRIPTION="D-Bus bindings for glib"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
+IUSE="debug doc static-libs test"
+
+CDEPEND=">=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}]"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+RDEPEND="${CDEPEND}
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-baselibs-20131008-r8
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+set_TBD() {
+ # out of sources build dir for make check
+ export TBD="${BUILD_DIR}-tests"
+}
+
+src_prepare() {
+ epatch_user
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --localstatedir="${EPREFIX}"/var
+ --enable-bash-completion
+ $(use_enable debug asserts)
+ $(use_enable static-libs static)
+ $(multilib_native_use_enable doc gtk-doc)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ use doc || ln -s "${S}"/doc/reference/html doc/reference/html #460042
+
+ if use test; then
+ set_TBD
+ mkdir "${TBD}"
+ cd "${TBD}"
+ einfo "Running configure in ${TBD}"
+ ECONF_SOURCE="${S}" econf \
+ "${myconf[@]}" \
+ $(use_enable test checks) \
+ $(use_enable test tests) \
+ $(use_enable test asserts) \
+ $(use_with test test-socket-dir "${T}"/dbus-test-socket)
+ fi
+}
+
+multilib_src_compile() {
+ emake
+
+ if use test; then
+ set_TBD
+ cd "${TBD}"
+ einfo "Running make in ${TBD}"
+ emake
+ fi
+}
+
+multilib_src_test() {
+ set_TBD
+ cd "${TBD}"
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newbashcomp "${ED}"/etc/bash_completion.d/dbus-bash-completion.sh dbus-send
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ prune_libtool_files
+}