summaryrefslogtreecommitdiff
path: root/dev-ml/cppo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/cppo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/cppo')
-rw-r--r--dev-ml/cppo/Manifest3
-rw-r--r--dev-ml/cppo/cppo-0.9.3.ebuild28
-rw-r--r--dev-ml/cppo/cppo-1.0.1.ebuild31
-rw-r--r--dev-ml/cppo/cppo-1.1.2.ebuild31
-rw-r--r--dev-ml/cppo/metadata.xml5
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-ml/cppo/Manifest b/dev-ml/cppo/Manifest
new file mode 100644
index 00000000000..f2afadad1eb
--- /dev/null
+++ b/dev-ml/cppo/Manifest
@@ -0,0 +1,3 @@
+DIST cppo-0.9.3.tar.gz 20393 SHA256 40a0acba9bd3b0bd8890ae2a87f479090bc4de7fa83b8ead028d08a34937923c SHA512 17726128d3c2cbd07fc70b8200f4a0a3ffed349c5d655bea9791302e88b0731cd93cdabd492e88db170fd1f6c4ed4760a65567c0265a7d1b745885be346c18b8 WHIRLPOOL ec865dff33d6278273dccb348d60d4aa783ae4348a164f08f578aef68200cbb7701fac03a39d8992a48869cf674390d0fa020c3910f62b93c4b13f96bb8c84df
+DIST cppo-1.0.1.tar.gz 21655 SHA256 bf08976e8d3bb1614094fec8e4066c6df178e2aa6f96b883fa571aaad3c6e1e4 SHA512 50f84d30c69c245db960ea11d1cc9f2b15d5333ae9f848387c212cc9a0f8e4383cc1bca10c351b460a0ef0849bed62c6a916869a036a985e267c167216c1ddb5 WHIRLPOOL c5f35ad25a4e4cfd11721ae41df5928fb65c2f20af0660a5729d6e59361bb18c819b624dd506d2fc81b165023c6b6711e695ef24b365c34f55af3173c556af81
+DIST cppo-1.1.2.tar.gz 24908 SHA256 975e0cb5e2751a604715eb042a059ef4965aff0318cf4c0553f215ed0964dfdd SHA512 dac094d21db26b867aa0db7461ca442a62ec6d9fd90a9da84ed66cca1764e227ebc86af222e3ba5120e431cf1aa1a7e5ae037cd2ecf6471c354a6181aa723086 WHIRLPOOL 6aac4b9067238fa1f4bccc9af612b47ab9dcddac0ed5855783a0bd52c44e829b74ffe048ab49dc7a3dfc7b59e1eb03f603dd0727cadbc1a9ca665990fcec17ee
diff --git a/dev-ml/cppo/cppo-0.9.3.ebuild b/dev-ml/cppo/cppo-0.9.3.ebuild
new file mode 100644
index 00000000000..ab205a97c75
--- /dev/null
+++ b/dev-ml/cppo/cppo-0.9.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/cppo/cppo-1.0.1.ebuild b/dev-ml/cppo/cppo-1.0.1.ebuild
new file mode 100644
index 00000000000..3d525ab5b35
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/cppo/cppo-1.1.2.ebuild b/dev-ml/cppo/cppo-1.1.2.ebuild
new file mode 100644
index 00000000000..3d525ab5b35
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/cppo/metadata.xml b/dev-ml/cppo/metadata.xml
new file mode 100644
index 00000000000..2193d772e35
--- /dev/null
+++ b/dev-ml/cppo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>