summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlpam
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ocamlpam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ocamlpam')
-rw-r--r--dev-ml/ocamlpam/Manifest1
-rw-r--r--dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch17
-rw-r--r--dev-ml/ocamlpam/metadata.xml5
-rw-r--r--dev-ml/ocamlpam/ocamlpam-1.1.ebuild37
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/ocamlpam/Manifest b/dev-ml/ocamlpam/Manifest
new file mode 100644
index 00000000000..31f56937679
--- /dev/null
+++ b/dev-ml/ocamlpam/Manifest
@@ -0,0 +1 @@
+DIST ocamlpam-1.1.tar.gz 7739 SHA256 e4e95614a858dc2d1991d789fa4d52d0e8181a1a097bba4933b2990b536e9b21 SHA512 84199a1e94db93952fd058c3bf03865c058abc0bb5fe09b489717e7aa77687496d40d80ed00be99e59e58c13b044356a05cae5f5aebf4faec470b66696042762 WHIRLPOOL dd94592ed42d0f84cafe894b12864c3b859bed4635af687d98b296414a9e6f8a83a47f47b3e8baaba1d7fd67d299b9dff9d960b582362247d6a47a00ae347e7b
diff --git a/dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch b/dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch
new file mode 100644
index 00000000000..c9450b7f30d
--- /dev/null
+++ b/dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch
@@ -0,0 +1,17 @@
+--- a/Makefile 2012-09-14 22:46:11.508415083 +0200
++++ b/Makefile 2012-09-14 22:46:34.526338371 +0200
+@@ -35,10 +35,13 @@
+
+ install:
+ install -d $(DESTDIR)/pam
+- install -m 644 -t $(DESTDIR)/pam META *.mli *.cmi *.cmx *.cma *.cmxa *.a
++ install -m 644 -t $(DESTDIR)/pam META *.mli *.cmi *.cma *.a
+ install -d $(DESTDIR)/stublibs
+ install -m 644 -t $(DESTDIR)/stublibs dll$(BASENAME).so
+
++install-opt:
++ install -m 644 -t $(DESTDIR)/pam *.cmx *.cmxa
++
+ dist: clean
+ mkdir -p $(DISTNAME)
+ -cp * $(DISTNAME)
diff --git a/dev-ml/ocamlpam/metadata.xml b/dev-ml/ocamlpam/metadata.xml
new file mode 100644
index 00000000000..2193d772e35
--- /dev/null
+++ b/dev-ml/ocamlpam/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlpam/ocamlpam-1.1.ebuild b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
new file mode 100644
index 00000000000..b2b67cd9ac2
--- /dev/null
+++ b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCamlPAM - an OCaml library for PAM"
+HOMEPAGE="http://sharvil.nanavati.net/projects/ocamlpam/"
+SRC_URI="http://sharvil.nanavati.net/projects/${PN}/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake META
+ emake byte
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${OCAMLFIND_DESTDIR}" install
+ use ocamlopt && emake DESTDIR="${OCAMLFIND_DESTDIR}" install-opt
+ dodoc CHANGES README
+}