summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-09 08:47:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-09 09:14:21 +0200
commit0155647a407669f341ce4007a56e627375419bca (patch)
treeb9bf07e564b883fda1915fb50218c38c24d4caa4 /dev-ml
parent06ef239fb9fc9da46b4f5230d0026a97b71e7002 (diff)
downloadgentoo-0155647a407669f341ce4007a56e627375419bca.tar.gz
gentoo-0155647a407669f341ce4007a56e627375419bca.tar.xz
dev-ml/ocaml-bigstring: Initial import, ebuild by me
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-bigstring/Manifest1
-rw-r--r--dev-ml/ocaml-bigstring/metadata.xml11
-rw-r--r--dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-bigstring/Manifest b/dev-ml/ocaml-bigstring/Manifest
new file mode 100644
index 00000000000..312dc11f276
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/Manifest
@@ -0,0 +1 @@
+DIST ocaml-bigstring-0.1.1.tar.gz 7671 SHA256 d09dad10711d5bf4e48601e09702186f5c1d12c7772e44e3ab9394d3839f2b27 SHA512 96aee494b9407b556b6eb554b0da66e24622f77d88aae6d822da60a3fb21477da8e7ae120f95f4f3c742b085ca4838f10ca0c8b2bcc4d23e35fd7de6af8532b3 WHIRLPOOL 59d3c570b024f292122052e9bbc9a8306032250cd95ecc18f9fcf6ebdf89ebc7db0060825cae18ad2271f99d75c1713d176a8b9bd1a457193f77d976aad49333
diff --git a/dev-ml/ocaml-bigstring/metadata.xml b/dev-ml/ocaml-bigstring/metadata.xml
new file mode 100644
index 00000000000..2e4acd90535
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">c-cube/ocaml-bigstring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
new file mode 100644
index 00000000000..84098f18ecb
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Overlay over bigarrays of chars"
+HOMEPAGE="https://github.com/c-cube/ocaml-bigstring/"
+SRC_URI="https://github.com/c-cube/ocaml-bigstring/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# ocamlfind: Package `QTest2Lib' not found
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ test? ( dev-ml/iTeML )
+"
+
+src_install() {
+ findlib_src_preinst
+ default
+}