summaryrefslogtreecommitdiff
path: root/dev-perl/Throwable/Throwable-0.200.13.ebuild
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-19 09:38:26 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-23 19:30:44 +0200
commit3d301f372d1f9876b1d13c35e97c70bf36b71157 (patch)
treeeacd78e7722614fed5f941497ec9eb370a119eae /dev-perl/Throwable/Throwable-0.200.13.ebuild
parentff4f95ab4f23b33dc01feddd3169e6c322bfaca5 (diff)
downloadgentoo-3d301f372d1f9876b1d13c35e97c70bf36b71157.tar.gz
gentoo-3d301f372d1f9876b1d13c35e97c70bf36b71157.tar.xz
dev-perl/Throwable: Bump to version 0.200.13
- EAPI6 Upstream: - Remove unused deps - Avoid memory leaks and infinite recursion when stringifiying Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Throwable/Throwable-0.200.13.ebuild')
-rw-r--r--dev-perl/Throwable/Throwable-0.200.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Throwable/Throwable-0.200.13.ebuild b/dev-perl/Throwable/Throwable-0.200.13.ebuild
new file mode 100644
index 00000000000..2a88a260475
--- /dev/null
+++ b/dev-perl/Throwable/Throwable-0.200.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.200013
+inherit perl-module
+
+DESCRIPTION="A role for classes that can be thrown"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Devel-StackTrace-1.320.0
+ >=dev-perl/Module-Runtime-0.2.0
+ >=dev-perl/Moo-1.0.1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"