summaryrefslogtreecommitdiff
path: root/dev-perl/Throwable/Throwable-0.200.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Throwable/Throwable-0.200.13.ebuild')
-rw-r--r--dev-perl/Throwable/Throwable-0.200.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Throwable/Throwable-0.200.13.ebuild b/dev-perl/Throwable/Throwable-0.200.13.ebuild
new file mode 100644
index 00000000000..2a88a260475
--- /dev/null
+++ b/dev-perl/Throwable/Throwable-0.200.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.200013
+inherit perl-module
+
+DESCRIPTION="A role for classes that can be thrown"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Devel-StackTrace-1.320.0
+ >=dev-perl/Module-Runtime-0.2.0
+ >=dev-perl/Moo-1.0.1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"