summaryrefslogtreecommitdiff
path: root/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-08-15 14:48:45 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-15 21:45:23 +0200
commit09725985ddbd95cc0b157cda8bb6f26f090664bf (patch)
tree4baad50ce47981010ee85aad7b04a45e07c36347 /dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
parent4b3ee710780bf0982efbb4ba3752a4fe3d8704d0 (diff)
downloadgentoo-09725985ddbd95cc0b157cda8bb6f26f090664bf.tar.gz
gentoo-09725985ddbd95cc0b157cda8bb6f26f090664bf.tar.xz
dev-python/python-fastimport: bump to 0.9.6, py3 support, update upstream
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2085 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/python-fastimport/python-fastimport-0.9.6.ebuild')
-rw-r--r--dev-python/python-fastimport/python-fastimport-0.9.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
new file mode 100644
index 00000000000..cf34531c688
--- /dev/null
+++ b/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN#python-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" -m unittest fastimport.tests.test_suite \
+ || die "Tests fail with ${EPYTHON}"
+}