summaryrefslogtreecommitdiff
path: root/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-fastimport/python-fastimport-0.9.6.ebuild')
-rw-r--r--dev-python/python-fastimport/python-fastimport-0.9.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
new file mode 100644
index 00000000000..cf34531c688
--- /dev/null
+++ b/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN#python-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" -m unittest fastimport.tests.test_suite \
+ || die "Tests fail with ${EPYTHON}"
+}