summaryrefslogtreecommitdiff
path: root/dev-python/twisted-core
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-09 21:44:37 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-09 21:47:06 -0500
commit6ec7fd1505906a225ac484f0b2632b617c85d323 (patch)
treea3106fc2243815b2e7a88288ea0b5e1ead75781b /dev-python/twisted-core
parent622e7892e0bfad4ef2f461a82a5553374b2fd7d7 (diff)
downloadgentoo-6ec7fd1505906a225ac484f0b2632b617c85d323.tar.gz
gentoo-6ec7fd1505906a225ac484f0b2632b617c85d323.tar.xz
dev-python/twisted: move blockers to RDEPEND
Diffstat (limited to 'dev-python/twisted-core')
-rw-r--r--dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild5
-rw-r--r--dev-python/twisted-core/twisted-core-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-core/twisted-core-15.1.0.ebuild2
-rw-r--r--dev-python/twisted-core/twisted-core-15.2.1.ebuild2
4 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild b/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
index 9ad0618b6f8..bca82a6434c 100644
--- a/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
+++ b/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
@@ -14,12 +14,13 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-f
IUSE="crypt gtk serial"
DEPEND="
- !dev-python/twisted
dev-python/zope-interface[${PYTHON_USEDEP}]
crypt? ( >=dev-python/pyopenssl-0.10[${PYTHON_USEDEP}] )
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-13.2.0.ebuild b/dev-python/twisted-core/twisted-core-13.2.0.ebuild
index a76b78a81c5..f6679b00a8e 100644
--- a/dev-python/twisted-core/twisted-core-13.2.0.ebuild
+++ b/dev-python/twisted-core/twisted-core-13.2.0.ebuild
@@ -14,12 +14,13 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86
IUSE="crypt gtk serial"
DEPEND="
- !dev-python/twisted
>=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
crypt? ( >=dev-python/pyopenssl-0.10[${PYTHON_USEDEP}] )
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-15.1.0.ebuild b/dev-python/twisted-core/twisted-core-15.1.0.ebuild
index 93f7667a2cb..78aad2ec8b1 100644
--- a/dev-python/twisted-core/twisted-core-15.1.0.ebuild
+++ b/dev-python/twisted-core/twisted-core-15.1.0.ebuild
@@ -19,9 +19,9 @@ RDEPEND=">=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
DEPEND="
- !dev-python/twisted
test? ( ${RDEPEND} )
"
+RDEPEND+=" !dev-python/twisted"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-15.2.1.ebuild b/dev-python/twisted-core/twisted-core-15.2.1.ebuild
index 4e7645a7af9..1ee03465cba 100644
--- a/dev-python/twisted-core/twisted-core-15.2.1.ebuild
+++ b/dev-python/twisted-core/twisted-core-15.2.1.ebuild
@@ -19,9 +19,9 @@ RDEPEND=">=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
DEPEND="
- !dev-python/twisted
test? ( ${RDEPEND} )
"
+RDEPEND+=" !dev-python/twisted"
PATCHES=(
# Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.