summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-03 13:57:03 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-03 22:03:21 +0800
commit580e90a3c6b155bee9501b1fe6c4180b591e44d3 (patch)
tree0008dac5d5b92ad89a08757ee8bdfb1ca36c7403 /dev-python
parentf31000f5ed040fea316a62a3dfac7b24c3c1d5f0 (diff)
downloadgentoo-580e90a3c6b155bee9501b1fe6c4180b591e44d3.tar.gz
gentoo-580e90a3c6b155bee9501b1fe6c4180b591e44d3.tar.xz
dev-python/jaraco-functools: bump to 1.11
Tests now pass even when another version is already installed, remove the src_prepare check. Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1189 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-functools/Manifest1
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-1.11.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/Manifest b/dev-python/jaraco-functools/Manifest
index 456cfa6f94c..4af53ed94fc 100644
--- a/dev-python/jaraco-functools/Manifest
+++ b/dev-python/jaraco-functools/Manifest
@@ -1,2 +1,3 @@
+DIST jaraco.functools-1.11.tar.gz 8260 SHA256 6ff4dc9f7e2dcfdf0ae877efcf8156a2a1645e1e5d5c15d6190650bd5adfc722 SHA512 db857fbc0e7ef6b9204e77d20a6a85e4a48a9d8747eeb9ff1ad5790929427a9b28d3b30d8d0a484aea19de6c3e838437ea45227a1e07a0f07aa6b53df29186d3 WHIRLPOOL 11528caadee59af0c09de853e60d780dfe9c9227fcada9e1a1da8689ca5bb395197de3b36638fa806442d5b77ee26e6d7f92c929f31baeaddf00508a84b218a6
DIST jaraco.functools-1.8.2.tar.gz 6549 SHA256 2766002fb0827e596744754158ceb5cfc4fba723567c756d39b9d7fbdb568ed0 SHA512 e655da8f812d21e20f671e5116357cea4f5ac1901715892c15a4284ea787e75c958ad087d73d0ad75c0a8bf6bb6b44d3ed3a6b68f9c393ae0de93063ecef8851 WHIRLPOOL 318679b1fcd3d9e8510a340bb5738608f4e0e1fac8229ca996925446921082339c6cf742ee353f8b08b08a777bfcce4c8384fd5f60482360699403014ed19dd1
DIST jaraco.functools-1.9.tar.gz 7220 SHA256 79a813f061ee16f431ac3828caca58b173d95d1518af144fa6307a92e90da496 SHA512 93b2cb1690bb9cf68b9f19b8964c7b660d35c2bd467ad724fe9d6169ae6a257aa2eab78da5bb49af14209991dc67df4ee7c7c03953fc753655aac924d5af550b WHIRLPOOL f49782df05f26513cdb5117b7412719498824e4394aa7557ba245dac35ff306c47412a4798713e2333c4ec700cbb78665da850e40cb499e8d961d815a0912acb
diff --git a/dev-python/jaraco-functools/jaraco-functools-1.11.ebuild b/dev-python/jaraco-functools/jaraco-functools-1.11.ebuild
new file mode 100644
index 00000000000..a3906db00d8
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-1.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.functools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}