summaryrefslogtreecommitdiff
path: root/dev-ruby/httparty
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-08-11 07:18:13 +0200
committerHans de Graaff <graaff@gentoo.org>2015-08-11 07:18:13 +0200
commitfd24cacdd0c0b4501416b2effd43732c0c52bc7f (patch)
treea076eaed8314b1d7b59ec1faa1f18920b7302324 /dev-ruby/httparty
parent759d3b9440c41434a8532e73b5788b2d268c91cf (diff)
downloadgentoo-fd24cacdd0c0b4501416b2effd43732c0c52bc7f.tar.gz
gentoo-fd24cacdd0c0b4501416b2effd43732c0c52bc7f.tar.xz
dev-ruby/httparty: avoid dependency on simplecov
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/httparty-0.13.5.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-ruby/httparty/httparty-0.13.5.ebuild b/dev-ruby/httparty/httparty-0.13.5.ebuild
index 111bb8a9509..f7bb43d7d4d 100644
--- a/dev-ruby/httparty/httparty-0.13.5.ebuild
+++ b/dev-ruby/httparty/httparty-0.13.5.ebuild
@@ -35,6 +35,10 @@ all_ruby_prepare() {
# Avoid test dependency on cucumber. We can't run the features since
# they depend on mongrel which is no longer packaged.
sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '1i require "cgi"' spec/spec_helper.rb || die
}
each_ruby_test() {