summaryrefslogtreecommitdiff
path: root/dev-ruby/httparty
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/httparty-0.13.5.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-ruby/httparty/httparty-0.13.5.ebuild b/dev-ruby/httparty/httparty-0.13.5.ebuild
index 111bb8a9509..f7bb43d7d4d 100644
--- a/dev-ruby/httparty/httparty-0.13.5.ebuild
+++ b/dev-ruby/httparty/httparty-0.13.5.ebuild
@@ -35,6 +35,10 @@ all_ruby_prepare() {
# Avoid test dependency on cucumber. We can't run the features since
# they depend on mongrel which is no longer packaged.
sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '1i require "cgi"' spec/spec_helper.rb || die
}
each_ruby_test() {