summaryrefslogtreecommitdiff
path: root/dev-util/fhist/files
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-21 13:38:35 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-21 13:38:35 +0100
commitb1a257f4a5459b0962dc72867aee2c39a893a6fb (patch)
tree229ff7118866b58c7e5ff4bbd2595bf0f6816749 /dev-util/fhist/files
parent1ee208eda5cff0fa670961122d80f944e11f039d (diff)
downloadgentoo-b1a257f4a5459b0962dc72867aee2c39a893a6fb.tar.gz
gentoo-b1a257f4a5459b0962dc72867aee2c39a893a6fb.tar.xz
dev-util/fhist: Version Bump and fix build failure with gcc-5
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=568962 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-util/fhist/files')
-rw-r--r--dev-util/fhist/files/fhist-1.21-ldflags.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/fhist/files/fhist-1.21-ldflags.patch b/dev-util/fhist/files/fhist-1.21-ldflags.patch
new file mode 100644
index 00000000000..00aab69d749
--- /dev/null
+++ b/dev-util/fhist/files/fhist-1.21-ldflags.patch
@@ -0,0 +1,40 @@
+ Makefile.in | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index ba4e4c2..c0e552a 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -916,8 +916,8 @@ common/libcommon.a: $(common_obj)
+ fcomp_obj = fcomp/main.$(OBJEXT)
+
+ bin/fcomp$(EXEEXT): $(fcomp_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fcomp_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fcomp_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fcomp$(EXEEXT): bin/fcomp$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fcomp$(EXEEXT) $@
+@@ -928,8 +928,8 @@ fhist_obj = fhist/breaks.$(OBJEXT) fhist/diff.$(OBJEXT) fhist/extract.$(OBJEXT)
+ fhist/subroutine.$(OBJEXT) fhist/update.$(OBJEXT)
+
+ bin/fhist$(EXEEXT): $(fhist_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fhist_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fhist_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fhist$(EXEEXT) $@
+@@ -937,8 +937,8 @@ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ fmerge_obj = fmerge/main.$(OBJEXT) fmerge/work.$(OBJEXT)
+
+ bin/fmerge$(EXEEXT): $(fmerge_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fmerge_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fmerge_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fmerge$(EXEEXT): bin/fmerge$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fmerge$(EXEEXT) $@