summaryrefslogtreecommitdiff
path: root/games-puzzle/xye/xye-0.12.2.ebuild
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-29 23:43:49 +0200
committerDavid Seifert <soap@gentoo.org>2016-12-29 23:45:54 +0200
commit979beea22f428225b0fccf740f0db25013c5948b (patch)
tree4dacc3e0e919524c42d7d8778249d56dda3d467a /games-puzzle/xye/xye-0.12.2.ebuild
parent0e23b9b8a512616e60193fbd3dc1499867ec05c5 (diff)
downloadgentoo-979beea22f428225b0fccf740f0db25013c5948b.tar.gz
gentoo-979beea22f428225b0fccf740f0db25013c5948b.tar.xz
games-puzzle/xye: Version bump to 0.12.2
Gentoo-bug: 600298 * EAPI=6 * Remove games.eclass Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-puzzle/xye/xye-0.12.2.ebuild')
-rw-r--r--games-puzzle/xye/xye-0.12.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-puzzle/xye/xye-0.12.2.ebuild b/games-puzzle/xye/xye-0.12.2.ebuild
new file mode 100644
index 00000000000..375906276fc
--- /dev/null
+++ b/games-puzzle/xye/xye-0.12.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Free version of the classic game Kye"
+HOMEPAGE="http://xye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xye/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-fonts/dejavu
+ media-libs/libsdl[video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.2-fix-buildsystem.patch
+ "${FILESDIR}"/${PN}-0.12.2-fix-c++14.patch
+ "${FILESDIR}"/${PN}-0.12.2-fix-desktop-file.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # create symlinks for previously bundled fonts
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf /usr/share/${PN}/res/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf /usr/share/${PN}/res/DejaVuSans-Bold.ttf
+}