summaryrefslogtreecommitdiff
path: root/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch')
-rw-r--r--net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch b/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
new file mode 100644
index 00000000000..c82f76d6001
--- /dev/null
+++ b/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
@@ -0,0 +1,29 @@
+index 860653d..82bdf2f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ include nasl.tmpl
+
+ all:
+- cd nasl && ${MAKE}
++ ${MAKE} -C nasl
+
+ nasl.tmpl: nasl.tmpl.in configure
+ $(SHELL) configure $(CONFIGURE_ARGS)
+--- a/nasl/Makefile
++++ b/nasl/Makefile
+@@ -97,11 +97,11 @@ cflags :
+ @echo "echo \"$(NESSUS_CFLAGS) $(include) $(DEFS) \"" > cflags
+ @chmod +x cflags
+
+-nasl : cflags $(OBJS) nasl.c
+- $(CC) $(CFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
++nasl : cflags $(OBJS) nasl.c libnasl.la
++ $(CC) $(CFLAGS) $(LDFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
+
+ libnasl.la : cflags $(OBJS)
+- $(COMPILE) $(NESSUS_LIBS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
++ $(COMPILE) $(NESSUS_LIBS) $(LDFLAGS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ install : libnasl.la nasl