summaryrefslogtreecommitdiff
path: root/x11-misc/peksystray
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/peksystray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/peksystray')
-rw-r--r--x11-misc/peksystray/Manifest2
-rw-r--r--x11-misc/peksystray/files/peksystray-0.4.0-asneeded.patch36
-rw-r--r--x11-misc/peksystray/metadata.xml10
-rw-r--r--x11-misc/peksystray/peksystray-0.2.1.ebuild28
-rw-r--r--x11-misc/peksystray/peksystray-0.4.0.ebuild28
5 files changed, 104 insertions, 0 deletions
diff --git a/x11-misc/peksystray/Manifest b/x11-misc/peksystray/Manifest
new file mode 100644
index 00000000000..8338718251d
--- /dev/null
+++ b/x11-misc/peksystray/Manifest
@@ -0,0 +1,2 @@
+DIST peksystray-0.2.1.tar.gz 70261 SHA256 1642322c50c893467c0e48ed0ced258e17e0df5c2f0415d6dcf4fe906f530793
+DIST peksystray-0.4.0.tar.bz2 73810 SHA256 30733b349bc7919171a6fa31023c8704eaae9158084a5210d49aa3210123a778
diff --git a/x11-misc/peksystray/files/peksystray-0.4.0-asneeded.patch b/x11-misc/peksystray/files/peksystray-0.4.0-asneeded.patch
new file mode 100644
index 00000000000..1fc376a8ac9
--- /dev/null
+++ b/x11-misc/peksystray/files/peksystray-0.4.0-asneeded.patch
@@ -0,0 +1,36 @@
+--- configure.in
++++ configure.in
+@@ -4,6 +4,7 @@
+ AM_INIT_AUTOMAKE(peksystray, 0.4.0)
+
+ AC_PROG_CC
++AC_PATH_X
+ AC_PATH_XTRA
+
+ dnl Are we going to enable the debugging output ??
+@@ -19,13 +20,7 @@
+ AC_DEFINE(DEBUG,,[Enable verbose debugging output])
+ fi
+
+-CFLAGS="$CFLAGS $X_CFLAGS"
+-#x_includes="-I$x_includes"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS"
+-#x_libraries="$X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS"
+-
+-AC_SUBST(x_includes)
+-AC_SUBST(x_libraries)
++AC_CHECK_LIB([X11], [XOpenDisplay])
+
+ AC_OUTPUT([
+ Makefile
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,7 +1,4 @@
+ bin_PROGRAMS = peksystray
+
+-INCLUDES = @x_includes@
+-
+-peksystray_LDADD = @x_libraries@
+-
+ peksystray_SOURCES = peksystray.c
++peksystray_LDADD = @X_PRE_LIBS@ @X_LIBS@ @X_EXTRA_LIBS@
diff --git a/x11-misc/peksystray/metadata.xml b/x11-misc/peksystray/metadata.xml
new file mode 100644
index 00000000000..c45a76de0a3
--- /dev/null
+++ b/x11-misc/peksystray/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">peksystray</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/peksystray/peksystray-0.2.1.ebuild b/x11-misc/peksystray/peksystray-0.2.1.ebuild
new file mode 100644
index 00000000000..ec018af1ed9
--- /dev/null
+++ b/x11-misc/peksystray/peksystray-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib
+
+DESCRIPTION="A system tray dockapp for window managers supporting docking"
+HOMEPAGE="http://freshmeat.net/projects/peksystray"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf --x-libraries=/usr/$(get_libdir) || die
+ emake || die
+}
+
+src_install() {
+ dobin src/peksystray
+ dodoc AUTHORS NEWS README THANKS TODO
+}
diff --git a/x11-misc/peksystray/peksystray-0.4.0.ebuild b/x11-misc/peksystray/peksystray-0.4.0.ebuild
new file mode 100644
index 00000000000..714634616ca
--- /dev/null
+++ b/x11-misc/peksystray/peksystray-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="A system tray dockapp for window managers supporting docking"
+HOMEPAGE="http://peksystray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_install() {
+ dobin src/peksystray || die
+ dodoc AUTHORS ChangeLog NEWS README REFS THANKS TODO
+}