summaryrefslogtreecommitdiff
path: root/app-portage/fetchcommandwrapper
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/fetchcommandwrapper')
-rw-r--r--app-portage/fetchcommandwrapper/Manifest2
-rw-r--r--app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.1.ebuild26
-rw-r--r--app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.2.ebuild26
-rw-r--r--app-portage/fetchcommandwrapper/metadata.xml11
4 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/fetchcommandwrapper/Manifest b/app-portage/fetchcommandwrapper/Manifest
new file mode 100644
index 00000000000..1fae8381e52
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/Manifest
@@ -0,0 +1,2 @@
+DIST fetchcommandwrapper-0.7.1.tar.gz 3187 SHA256 083eab79afadeadc00e9ad1dce77a54511df1a1e7b48c61c886012b565eba066 SHA512 be1e382180606d527f85c2f45888373286687c2b521c66cb11ed90f05e107bb54cbfe83b0509bf52e31108db3a52b9089259c83e63cae3a1d25dbca583faaf74 WHIRLPOOL dd9bda47ba066fc5ccab658b8914627ab14e0914ccc00541486910e7e2acc974016dacd7e40f86d6782adce45e9948cece74d09611ca965cceb110a491fc650e
+DIST fetchcommandwrapper-0.7.2.tar.gz 3134 SHA256 0ccab9876c6d2ed15c972aa5287069e2f2c503b9b36f6246b15be12eb7ec05b8 SHA512 f268cbef691320106b3f929b0ab3b63085ffdd3e1988fbada2d37c6abcdf7e417758055fff503bb70490840dfde7704e87bb7434faa1d1115cc42729ad10de61 WHIRLPOOL 1c9f2a5681a49a62e06003811a7903d58c816f34a38acf2c424238af58f32e48b0181d034c6ed2b44dcf3e4438ba1a45feb82315e263f5638a5c9fffe2f4b6a3
diff --git a/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.1.ebuild b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.1.ebuild
new file mode 100644
index 00000000000..7d5854c706a
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrapper integrating aria2 into portage's FETCHCOMMAND"
+HOMEPAGE="https://github.com/gentoo/fetchcommandwrapper"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-misc/aria2-1.10.2"
+
+pkg_postinst() {
+ ewarn 'You need to append'
+ ewarn ' source /usr/share/fetchcommandwrapper/make.conf'
+ ewarn 'to /etc/portage/make.conf in order to integrate fetchcommandwrapper.'
+}
diff --git a/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.2.ebuild b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.2.ebuild
new file mode 100644
index 00000000000..7d5854c706a
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.7.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrapper integrating aria2 into portage's FETCHCOMMAND"
+HOMEPAGE="https://github.com/gentoo/fetchcommandwrapper"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-misc/aria2-1.10.2"
+
+pkg_postinst() {
+ ewarn 'You need to append'
+ ewarn ' source /usr/share/fetchcommandwrapper/make.conf'
+ ewarn 'to /etc/portage/make.conf in order to integrate fetchcommandwrapper.'
+}
diff --git a/app-portage/fetchcommandwrapper/metadata.xml b/app-portage/fetchcommandwrapper/metadata.xml
new file mode 100644
index 00000000000..48795f79680
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gentoo/fetchcommandwrapper</remote-id>
+ </upstream>
+</pkgmetadata>