summaryrefslogtreecommitdiff
path: root/app-portage/porticron
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/porticron')
-rw-r--r--app-portage/porticron/Manifest1
-rw-r--r--app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch26
-rw-r--r--app-portage/porticron/metadata.xml11
-rw-r--r--app-portage/porticron/porticron-0.7_p20140126.ebuild32
4 files changed, 70 insertions, 0 deletions
diff --git a/app-portage/porticron/Manifest b/app-portage/porticron/Manifest
new file mode 100644
index 00000000000..71626d3143a
--- /dev/null
+++ b/app-portage/porticron/Manifest
@@ -0,0 +1 @@
+DIST porticron-0.7_p20140126.tar.gz 4453 SHA256 46b61958a182d9cdd73dbea76a017855eebc4780dc75692503c0d1e7ff0ea482 SHA512 c14c5ff18eff74d7c225883dc0e1cea16666f0dcab07f9b249aed0db2874179eacc824c0f35dc2cfd97dc0c2db5f2bf6d13c3e76a2cd1b87de46fb073622f3d5 WHIRLPOOL f932a2319be582b564412badb456daf0fd86e3991ffc63fa25718337669b860097ac6d446a220f4e56e3a97cb8660a9f2bd25eeb1c54a2921fb0c7d6991bad5b
diff --git a/app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch b/app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch
new file mode 100644
index 00000000000..4531ab638fd
--- /dev/null
+++ b/app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch
@@ -0,0 +1,26 @@
+From 7a7002d5af62d0a4791a386cdc3560330f27f1c0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rainer=20M=C3=BCller?= <raimue@codingfarm.de>
+Date: Sun, 26 Jan 2014 23:23:03 +0100
+Subject: [PATCH] Avoid the deprecated `portageq portdir'
+
+This implements the fix proposed in hollow/porticron#6.
+---
+ bin/porticron | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bin/porticron b/bin/porticron
+index d168b27..86a1f70 100755
+--- a/bin/porticron
++++ b/bin/porticron
+@@ -117,7 +117,7 @@ FQDN=$(hostname --fqdn)
+ HOST=$(hostname -s)
+ IP=$(dig +short ${FQDN} | tr '\n' ' ')
+ DATE=$(date -R)
+-PORTDIR=$(portageq portdir)
++PORTDIR=$(portageq get_repo_path $(portageq envvar EROOT) gentoo)
+
+ # replace variables
+ for var in FQDN HOST IP DATE; do
+--
+1.8.5.1
+
diff --git a/app-portage/porticron/metadata.xml b/app-portage/porticron/metadata.xml
new file mode 100644
index 00000000000..3386e5a0be8
--- /dev/null
+++ b/app-portage/porticron/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gentoo/porticron</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/porticron/porticron-0.7_p20140126.ebuild b/app-portage/porticron/porticron-0.7_p20140126.ebuild
new file mode 100644
index 00000000000..aaa786f89a8
--- /dev/null
+++ b/app-portage/porticron/porticron-0.7_p20140126.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="cron script to sync portage and send update mails to root"
+HOMEPAGE="https://github.com/gentoo/porticron"
+SRC_URI="https://github.com/hollow/${PN}/tarball/df727fe -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ app-portage/gentoolkit
+ net-dns/bind-tools
+"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-portage-2.2.8.patch
+}
+
+src_install() {
+ dosbin bin/porticron
+ insinto /etc
+ doins etc/porticron.conf
+}