summaryrefslogtreecommitdiff
path: root/app-shells/posh
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/posh')
-rw-r--r--app-shells/posh/Manifest3
-rw-r--r--app-shells/posh/files/posh-glibc-2.16.patch19
-rw-r--r--app-shells/posh/metadata.xml7
-rw-r--r--app-shells/posh/posh-0.10.2.ebuild28
-rw-r--r--app-shells/posh/posh-0.11.ebuild28
-rw-r--r--app-shells/posh/posh-0.12.ebuild28
6 files changed, 113 insertions, 0 deletions
diff --git a/app-shells/posh/Manifest b/app-shells/posh/Manifest
new file mode 100644
index 00000000000..c36180875b4
--- /dev/null
+++ b/app-shells/posh/Manifest
@@ -0,0 +1,3 @@
+DIST posh_0.10.2.tar.gz 469338 SHA256 6ee7e8e2d181953efbcd991cc0e66c98c7d2a0511f1697889e239a93d625f0a1 SHA512 4abde6415eaf199f5a7998e8a8fc6ed0dd07fb2ec95724bc01ba18f01f0d9b1a0af04d6ea59e302407f9a32f7ef7555e24f48005f795390bda3ecd01e55b5878 WHIRLPOOL 208a9e97bdf3846abe2285eb21c40be0f004d4e2a72785cbb22f12830f681268a303ba0d6f3baf54a7a9f6a3933ead2cfda80e7b3fefeb9a6e7f03d39d7ee80f
+DIST posh_0.11.tar.gz 469798 SHA256 0d9b54db168e6fc7f93676d188e460988017868ffac5987b76d4fb18c2008f6f SHA512 2d4319600f4356e0b661403648c62078e87fbac0ac418a4985ebfcf6277bd26a8dd8462f61676194cd547f3c9aa31e1713fc1b562d63466511dbf8845d7a06aa WHIRLPOOL f546f9ff07daba992d9ac897ac77fdbfbca92a393640b1226c01c271cdbbb57a4d0015c5d5a463a6b1505ec2cd168f8ed2bca8a75be9189de1c27e295558500e
+DIST posh_0.12.tar.gz 469680 SHA256 9206b67005cf357404b3f3021c2d7c7bbd50756050512dececb9ed836435b048 SHA512 bb98d2fa009b5ccd666103378dd30da5649baf830d4e3124575f813b98b13275bde46e03bb737c75b37c82f655b3f17e9a5decd29b75d20678e78a4d7e3abf00 WHIRLPOOL ffd03e1537aa8e68545c532fb8c27fc9702ab16157efce7ef5c83b6f70fbe1a807e4759b85525036ae0c26f56b595ccf95d9cffb8a96b4ef8e5a8ec4b50c60e6
diff --git a/app-shells/posh/files/posh-glibc-2.16.patch b/app-shells/posh/files/posh-glibc-2.16.patch
new file mode 100644
index 00000000000..8c29def10f7
--- /dev/null
+++ b/app-shells/posh/files/posh-glibc-2.16.patch
@@ -0,0 +1,19 @@
+Description: explicitly include sys/resource.h, for eglibc 2.16
+ sys/resource.h is no longer included by sys/wait.h
+ http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=d94a4670800de6e8f088b8630ad5142866127980
+Author: Stefano Rivera <stefanor@ubuntu.com>
+Last-Updated: 2012-11-07
+
+--- a/ksh_wait.h
++++ b/ksh_wait.h
+@@ -5,6 +5,10 @@
+ # include <sys/wait.h>
+ #endif
+
++#ifdef HAVE_SYS_RESOURCE_H
++# include <sys/resource.h>
++#endif
++
+ #ifndef POSIX_SYS_WAIT
+ /* Get rid of system macros (which probably use union wait) */
+ # undef WIFCORED
diff --git a/app-shells/posh/metadata.xml b/app-shells/posh/metadata.xml
new file mode 100644
index 00000000000..1df89af114a
--- /dev/null
+++ b/app-shells/posh/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/posh/posh-0.10.2.ebuild b/app-shells/posh/posh-0.10.2.ebuild
new file mode 100644
index 00000000000..954515077cd
--- /dev/null
+++ b/app-shells/posh/posh-0.10.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit autotools-utils
+
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="http://packages.debian.org/posh"
+SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-glibc-2.16.patch
+)
+
+src_configure() {
+ myeconfargs=(
+ --exec-prefix=/
+ )
+ autotools-utils_src_configure
+}
diff --git a/app-shells/posh/posh-0.11.ebuild b/app-shells/posh/posh-0.11.ebuild
new file mode 100644
index 00000000000..954515077cd
--- /dev/null
+++ b/app-shells/posh/posh-0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit autotools-utils
+
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="http://packages.debian.org/posh"
+SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-glibc-2.16.patch
+)
+
+src_configure() {
+ myeconfargs=(
+ --exec-prefix=/
+ )
+ autotools-utils_src_configure
+}
diff --git a/app-shells/posh/posh-0.12.ebuild b/app-shells/posh/posh-0.12.ebuild
new file mode 100644
index 00000000000..34d2e996fc6
--- /dev/null
+++ b/app-shells/posh/posh-0.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="http://packages.debian.org/posh"
+SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT=test
+
+#PATCHES=(
+# "${FILESDIR}"/${PN}-glibc-2.16.patch
+#)
+
+src_configure() {
+ myeconfargs=(
+ --exec-prefix=/
+ )
+ autotools-utils_src_configure
+}