summaryrefslogtreecommitdiff
path: root/gnustep-apps/zipper
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps/zipper')
-rw-r--r--gnustep-apps/zipper/Manifest3
-rw-r--r--gnustep-apps/zipper/metadata.xml8
-rw-r--r--gnustep-apps/zipper/zipper-1.3.ebuild28
-rw-r--r--gnustep-apps/zipper/zipper-1.4.ebuild27
-rw-r--r--gnustep-apps/zipper/zipper-1.5.ebuild17
5 files changed, 83 insertions, 0 deletions
diff --git a/gnustep-apps/zipper/Manifest b/gnustep-apps/zipper/Manifest
new file mode 100644
index 00000000000..b2d5c72b4a0
--- /dev/null
+++ b/gnustep-apps/zipper/Manifest
@@ -0,0 +1,3 @@
+DIST Zipper-1.3.tar.gz 470821 SHA256 fd6df5f8aef351282147a2820bd39b4b8c7561e42e743008c19e3f733d678931
+DIST Zipper-1.4.tar.gz 77505 SHA256 845af38826811d844d666efe6269c1f8555913d907027d98cb347df940006941 SHA512 ca43dac6f8a562ab4d8f7c8d7401f409f32146961cbf475d625244fb7f352ac5c32e1ac987280c9d409d3acc6f2cc8173a8f6392360e8d86432f115d90a3c357 WHIRLPOOL 4a7eaa7a1ef76f8ece00786235b16bcb4fd12e0e79c407fdec4c075183ca57b18c49d6f88d286ff385d68092aea5ee46fd2c2f91039fc02766aa52e6f906c8d7
+DIST Zipper-1.5.tar.gz 81557 SHA256 3ecf9cd7e2242c62e38a4933ce4f3da35e90f52ca94ac030a1f2a717e6561392 SHA512 4b3353c0513f6fb4431778d03a4f980a592d19bbb3dcaface5c618b88a9c76bb7d067cca38fe20ccafc6c3636cd6b2e17b2a2e273673b2ba1153faa6f68ef348 WHIRLPOOL fe45e34d9f56a0b5dafc5a16c3bf29b2601a6bcb9c49c4a3bf40980264702c7e99c0d9579f27e02472d51a4d88e54eb1f1be40e4c938d73657e863912e381145
diff --git a/gnustep-apps/zipper/metadata.xml b/gnustep-apps/zipper/metadata.xml
new file mode 100644
index 00000000000..4759288a4c3
--- /dev/null
+++ b/gnustep-apps/zipper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+Zipper is a tool for inspecting the contents of a compressed archive and for extracting.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/zipper/zipper-1.3.ebuild b/gnustep-apps/zipper/zipper-1.3.ebuild
new file mode 100644
index 00000000000..d0fbf6c7dca
--- /dev/null
+++ b/gnustep-apps/zipper/zipper-1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/z/Z}
+
+DESCRIPTION="Zipper is a tool for inspecting and extracting compressed archives"
+HOMEPAGE="http://xanthippe.dyndns.org/Zipper/"
+SRC_URI="http://xanthippe.dyndns.org/Zipper/${P/z/Z}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="gnustep-libs/renaissance"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+
+ elog "Optional archives programs zipper can use:"
+ elog "app-arch/unzip (ZIP files)"
+ elog "app-arch/lha (LZH archives)"
+ elog "app-arch/unlzx (Amiga LZX archives)"
+ elog "app-arch/rar (RAR files)"
+}
diff --git a/gnustep-apps/zipper/zipper-1.4.ebuild b/gnustep-apps/zipper/zipper-1.4.ebuild
new file mode 100644
index 00000000000..08cc0c5b158
--- /dev/null
+++ b/gnustep-apps/zipper/zipper-1.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit gnustep-2
+
+S=${WORKDIR}/${P/z/Z}
+
+DESCRIPTION="Zipper is a tool for inspecting and extracting compressed archives"
+HOMEPAGE="http://gap.nongnu.org/zipper"
+SRC_URI="http://savannah.nongnu.org/download/gap/${P/z/Z}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+
+ elog "Optional archives programs zipper can use:"
+ elog "app-arch/unzip (ZIP files)"
+ elog "app-arch/lha (LZH archives)"
+ elog "app-arch/unlzx (Amiga LZX archives)"
+ elog "app-arch/rar (RAR files)"
+}
diff --git a/gnustep-apps/zipper/zipper-1.5.ebuild b/gnustep-apps/zipper/zipper-1.5.ebuild
new file mode 100644
index 00000000000..b791dcdc725
--- /dev/null
+++ b/gnustep-apps/zipper/zipper-1.5.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit gnustep-2
+
+S=${WORKDIR}/${P/z/Z}
+
+DESCRIPTION="Zipper is a tool for inspecting and extracting compressed archives"
+HOMEPAGE="http://gap.nongnu.org/zipper"
+SRC_URI="http://savannah.nongnu.org/download/gap/${P/z/Z}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""