summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpxpy
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpxpy')
-rw-r--r--sci-geosciences/gpxpy/Manifest1
-rw-r--r--sci-geosciences/gpxpy/gpxpy-0.8.6.ebuild27
-rw-r--r--sci-geosciences/gpxpy/metadata.xml11
3 files changed, 39 insertions, 0 deletions
diff --git a/sci-geosciences/gpxpy/Manifest b/sci-geosciences/gpxpy/Manifest
new file mode 100644
index 00000000000..b4e49171117
--- /dev/null
+++ b/sci-geosciences/gpxpy/Manifest
@@ -0,0 +1 @@
+DIST gpxpy-0.8.6.tar.gz 65569 SHA256 e94a1cf8d37459aa2444e1cd31e2670832757c6caa958f4960c710a087b01148 SHA512 3c180436210689724f88fdac43576a9a11b3f8717fb6f8acd7c8ce0afc1219714b4c83f1ba4f64487d35d0189d65a311d77f7778e7d84f315b251d1098f8989c WHIRLPOOL 07ae9a417ce638898f59849d05c0ee23f0f3afcbff9509ca69a2eba15787be18db3740709eb2463b0e03d45e357b9e35bc03b22824b8551e7361884a70210fd8
diff --git a/sci-geosciences/gpxpy/gpxpy-0.8.6.ebuild b/sci-geosciences/gpxpy/gpxpy-0.8.6.ebuild
new file mode 100644
index 00000000000..a79d33b7349
--- /dev/null
+++ b/sci-geosciences/gpxpy/gpxpy-0.8.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="python GPX parser"
+HOMEPAGE="https://github.com/tkrajina/gpxpy"
+SRC_URI="https://github.com/tkrajina/${PN}/tarball/85c3477b -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( NOTICE.txt README.md )
+
+python_test() {
+ ${PYTHON} -m unittest test
+}
diff --git a/sci-geosciences/gpxpy/metadata.xml b/sci-geosciences/gpxpy/metadata.xml
new file mode 100644
index 00000000000..9c5da11928f
--- /dev/null
+++ b/sci-geosciences/gpxpy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tkrajina/gpxpy</remote-id>
+ </upstream>
+</pkgmetadata>