summaryrefslogtreecommitdiff
path: root/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mmdb/mmdb-2.0.5-r1.ebuild')
-rw-r--r--sci-libs/mmdb/mmdb-2.0.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild b/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild
new file mode 100644
index 00000000000..d9a8ad2243d
--- /dev/null
+++ b/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="The Coordinate Library for working with CCP4 coordinate files"
+HOMEPAGE="https://launchpad.net/mmdb/"
+SRC_URI="ftp://ftp.ccp4.ac.uk/opensource/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}