summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mmdb/mmdb-2.0.5-r1.ebuild (renamed from sci-libs/mmdb/mmdb-2.0.5.ebuild)15
1 files changed, 14 insertions, 1 deletions
diff --git a/sci-libs/mmdb/mmdb-2.0.5.ebuild b/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild
index c19513a7729..d9a8ad2243d 100644
--- a/sci-libs/mmdb/mmdb-2.0.5.ebuild
+++ b/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,3 +15,16 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="static-libs"
S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}