summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-01-06 12:53:57 +0000
committerJustin Lecher <jlec@gentoo.org>2018-01-06 13:35:36 +0000
commit87ac2c93178e64c1e36a9cd01c0cd346cea6ce7d (patch)
treec646d89157e3dfc796d9ff97d0366c37302324ee /sci-libs
parent7da9e67c54c9144bcb6eb42de7b5c1d21c7d8c9b (diff)
downloadgentoo-87ac2c93178e64c1e36a9cd01c0cd346cea6ce7d.tar.gz
gentoo-87ac2c93178e64c1e36a9cd01c0cd346cea6ce7d.tar.xz
sci-libs/mmdb: Build shared libs
Closes: https://bugs.gentoo.org/641534 Closes: https://bugs.gentoo.org/642944 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mmdb/mmdb-2.0.5-r1.ebuild (renamed from sci-libs/mmdb/mmdb-2.0.5.ebuild)15
1 files changed, 14 insertions, 1 deletions
diff --git a/sci-libs/mmdb/mmdb-2.0.5.ebuild b/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild
index c19513a7729..d9a8ad2243d 100644
--- a/sci-libs/mmdb/mmdb-2.0.5.ebuild
+++ b/sci-libs/mmdb/mmdb-2.0.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,3 +15,16 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="static-libs"
S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}