summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-04-07 22:12:58 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-07 22:32:01 +0200
commit4926c104760c62609b5ad32fff80b28070ec24e7 (patch)
tree69e57e77b4b9cfb8b6241f19b46aad561d7a0dea /gnu/packages/engineering.scm
parentace3a7ad89b1cc5c16cf2455248014b222b0f945 (diff)
downloadguix-4926c104760c62609b5ad32fff80b28070ec24e7.tar.gz
guix-4926c104760c62609b5ad32fff80b28070ec24e7.tar.xz
gnu: Add python-pynest2d.
* gnu/packages/engineering.scm (python-pynest2d): New variable.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index a1f96771a1..ff528af8fb 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3463,6 +3463,54 @@ from Ultimaker.")
problem. It was inspired from the SVGNest Javascript library.")
(license license:lgpl3)))
+(define-public python-pynest2d
+ (package
+ (name "python-pynest2d")
+ (version "4.12.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ultimaker/pynest2d")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jhqfylg6vzlbz9rqs981bg6y8s18iklw1p8hmax72xq2c7561s1"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list boost
+ clipper
+ libnest2d-for-cura
+ nlopt
+ python
+ python-sip-4))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-clipper-detection
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CLIPPER_PATH" (assoc-ref inputs "clipper"))))
+ (add-before 'configure 'fix-python-sitearch
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((path (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (substitute* "cmake/FindSIP.cmake"
+ (("\\$\\{_process_output\\} Python3_SITEARCH")
+ (string-append path " Python3_SITEARCH"))
+ (("\\$\\{_process_output\\} Python3_SITELIB")
+ (string-append path " Python3_SITELIB")))))))))
+ (home-page "https://github.com/Ultimaker/pynest2d")
+ (synopsis "Python bindings for libnest2d")
+ (description
+ "This package contains CPython bindings for libnest2d-for-cura.")
+ (license license:lgpl3+)))
+
(define-public libcharon
(package
(name "libcharon")