summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-01 00:26:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:23 -0400
commit5289d2851582c31b698b0a7faaa0d216db86b810 (patch)
tree0e053ae833064d9e1fcf5d079bacc0a85d881c7c /gnu/packages/tex.scm
parent5d40463875703b2aca792bb60581eda2b8f82bbf (diff)
downloadguix-5289d2851582c31b698b0a7faaa0d216db86b810.tar.gz
guix-5289d2851582c31b698b0a7faaa0d216db86b810.tar.xz
gnu: Add texlive-cs.
* gnu/packages/tex.scm (texlive-cs): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f8fa65e386..82da10c41a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4081,6 +4081,37 @@ polyglossia package rather than Babel.")
(define-deprecated-package texlive-latex-babel texlive-babel)
+(define-public texlive-cs
+ (package
+ (inherit (simple-texlive-package
+ "texlive-cs"
+ (list
+ "fonts/enc/dvips/cs/"
+ "fonts/map/dvips/cs/"
+ "fonts/source/public/cs/"
+ ;; TODO: Remove these pre-built files after the manual
+ ;; build below is fixed.
+ ;; The font fails to build from the Metafont sources, with
+ ;; errors such as:
+ ;; This is METAFONT, Version 2.71828182 (TeX Live 2021/GNU Guix) [...]
+ ;; (./csaccent.mf
+ ;; >> cap_curve#-dot_size#
+ ;; ! Unknown relation will be considered false.
+ ;; <to be read again>
+ "fonts/tfm/cs/cs-a35/"
+ "fonts/tfm/cs/cs-charter/"
+ "fonts/tfm/public/cs/"
+ "fonts/type1/public/cs/"
+ "fonts/vf/cs/cs-a35/")
+ (base32 "1ww5lrqja051fh0ygmfdyy5a6bhwq9k5zv857vwiqf5syvw5djps")
+ #:trivial? #t))
+ (home-page "http://petr.olsak.net/cstex/")
+ (synopsis "Czech/Slovak-tuned Computer Modern fonts")
+ (description "This package provides Czech/Slovak-tuned Computer Modern
+fonts in the Metafont format; Type 1 format versions (csfonts-t1) are also
+available.")
+ (license license:gpl2+))) ;see fonts/source/public/cs/cscode.mf
+
;;; Note: if this package is modified, its name must be changed to comply with
;;; its license.
(define-public texlive-csplain