summaryrefslogtreecommitdiff
path: root/dev-python/libiscsi-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libiscsi-python')
-rw-r--r--dev-python/libiscsi-python/Manifest1
-rw-r--r--dev-python/libiscsi-python/libiscsi-python-0_pre160211.ebuild25
-rw-r--r--dev-python/libiscsi-python/libiscsi-python-9999.ebuild22
-rw-r--r--dev-python/libiscsi-python/metadata.xml11
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/libiscsi-python/Manifest b/dev-python/libiscsi-python/Manifest
new file mode 100644
index 00000000000..153c5ea581e
--- /dev/null
+++ b/dev-python/libiscsi-python/Manifest
@@ -0,0 +1 @@
+DIST libiscsi-python-0_pre160211.zip 110062 SHA256 5165edc59a696b200c5572a21a4fcf258d7cde32983ad56e0b92e2ca71ec4e37 SHA512 c3f3742d2471f038c93ccd61e3eccf0431242988bc1237e3a0047518fb1eef71c5092735bc323452fae2219ee5a89de1fe098cd1170174934b547b44319d465c WHIRLPOOL ea4034821f6540516132df8e005b4910281091b4b8b5d2d5bf7e4044b5437f74c9e137e530b0982f0803e81a6185a6a03120ba2b3cd7f266607f493a3fe106b8
diff --git a/dev-python/libiscsi-python/libiscsi-python-0_pre160211.ebuild b/dev-python/libiscsi-python/libiscsi-python-0_pre160211.ebuild
new file mode 100644
index 00000000000..e183885be91
--- /dev/null
+++ b/dev-python/libiscsi-python/libiscsi-python-0_pre160211.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+HASH="a8f548c2700dbe3dadfe048fa2491c7b77cf7846"
+
+DESCRIPTION="Python bindings for libiscsi"
+HOMEPAGE="https://github.com/sahlberg/libiscsi-python"
+SRC_URI="https://github.com/sahlberg/libiscsi-python/archive/${HASH}.zip -> ${P}.zip"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="net-libs/libiscsi"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-${HASH}
diff --git a/dev-python/libiscsi-python/libiscsi-python-9999.ebuild b/dev-python/libiscsi-python/libiscsi-python-9999.ebuild
new file mode 100644
index 00000000000..0141c976686
--- /dev/null
+++ b/dev-python/libiscsi-python/libiscsi-python-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python bindings for libiscsi"
+HOMEPAGE="https://github.com/sahlberg/libiscsi-python"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/sahlberg/libiscsi-python.git"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="net-libs/libiscsi"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/libiscsi-python/metadata.xml b/dev-python/libiscsi-python/metadata.xml
new file mode 100644
index 00000000000..0f3589e95f6
--- /dev/null
+++ b/dev-python/libiscsi-python/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>